Subscribe to our newsletter - Assistenza tecnica:199422456

I purchased a new logger, why do I need to update the software?

If you already have a Tecnosoft system and after a certain period, more or less long, buy another device compatible with your software, it is appropriate and in some cases mandatory to update the software itself. The version you are currently using may be antecedent to the development of the new device you purchased and therefore may not recognize it or not handle it properly.

More faqs